Sde community hangs intelliJ 3.0.5 on XP

hello.

i installed the sde community edition (sdeceij_20040414.exe) on
intelliJ 3.0.5 on Win XP SP1.
everything seems to have gone ok with the install except that when i start IntelliJ now it hangs on the splash screen.

any ideas?

my first priority is to get my IDE back up, but
actually getting this thing running would also be nice.

(this’ll teach me to try new things on the IDE install
i need to code with…
what WAS i thinking ?!?)

below is an exception from idea.log.

2004-06-08 11:55:17,924 [ 1329] ERROR -
intellij.plugins.PluginManager - Original exception:
java.lang.NoClassDefFoundError: com/intellij/openapi/fileEditor/FileEditorProvider
at java.lang.ClassLoader.defineClass0(Native Method)
at java.lang.ClassLoader.defineClass(Unknown Source)
at java.lang.ClassLoader.defineClass(Unknown Source)
at com.intellij.ide.j.a.a.a(a.java:10)
at com.intellij.ide.j.a.a.findClass(a.java:16)
at com.intellij.ide.j.a.c.loadClass(c.java:8)
at java.lang.ClassLoader.loadClass(Unknown Source)
at com.intellij.ide.j.a.b.loadClass(b.java:31)
at java.lang.ClassLoader.loadClass(Unknown Source)
at java.lang.ClassLoader.loadClassInternal(Unknown Source)
at java.lang.Class.forName0(Native Method)
at java.lang.Class.forName(Unknown Source)
at com.intellij.openapi.components.a.a.a(a.java:138)
at com.intellij.idea.g.a(g.java:2)
at com.intellij.openapi.application.b.e.(e.java:71)
at com.intellij.openapi.application.b.f.(f.java)
at com.intellij.idea.v.(v.java:13)
at com.intellij.idea.j.a(j.java)
at com.intellij.idea.k.run(k.java:0)
at com.intellij.ide.f.j.a(j.java:128)
at com.intellij.ide.f.j.a(j.java:134)
at com.intellij.idea.Main.a(Main.java:53)
at com.intellij.idea.Main.start(Main.java:40)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
at java.lang.reflect.Method.invoke(Unknown Source)
at com.intellij.ide.j.d.run(d.java:8)
at java.lang.Thread.run(Unknown Source)

even though i used the installer, removing the files shown in the
"no installer" install instructions (in the Uninstall section)
brought IntelliJ back to life.

http://www.visual-paradigm.com/edocs.php?url=content/product/sde/sdeij/sdeijUserGuide/html/appendixa.html&resourceType=document&resourceDetail=sdeijUserGuide

thus the immediate problem is solved.

I had the same problem on Windows 2000 SP4 using IntelliJ 3.0.5.

I also found that moving the file <IntelliJ_Home>\plugins\sdeIJ\lib\vpsdeij.jar outside the install path will allow IntelliJ to start normally (without SDE).