Strange behavior w Community License installed

I downloaded and install vplicense.vpl.
After installing vplicense ,any diagram view window is never showed up.
Without installing vplicense, diagram view window is showed up but whole view is blacked out.

There is no specific error or warning in log.

Any idea or suggestion to solve this?

My environment is this.
OS:Mac OS X 10.2.6
HotSpot:1.4.1_01-14, mixed mode

Hi Atsushi,
I think you are using the Mac Look and feel. Please change to Meta look and feel. We have found the bug and the fix will available 2.1 version.

Best Regards,

Hi Angus,

I tried v 2.1 and half of problems has been solved, great!

However, diagram’s background color is still blacked out. Changing background color is not effective at all.

Best regards,


I found out it happend because of Grid drawing.
Turn “Grid visible” option off and it solved !
I tried change “Grid Width” and “Grid Height” from 2 to 100, but nothing is effective.

We will try to fix this problem. Thank you for reporting.

Applying Java 1.4.1 update1 for Mac OS X solved this problem and vpuml just works fine.

However, this update bring other issues(?) with ver 2.2 installer, though.

Could you give more detail?