Swimlanes cannot be reduced in size


I am using BPVA version 3.2 (build sp1_20100313) on Windows XP. I find the swimlane behavior to be frustrating. I have a BP diagram that will not fit on a page when I print because the swimlanes will not collapse to match the diagram elements. It can make it taller, but not narrower.

Also what are the gray bars (vertical and horizontal) that will show up when I get near the edge of the diagram? They appear to be related to the page margins but do not seem to do anything.

Thanks in advance.


Hi FatherAntox,

Thanks for your post. The pool is resizable - you can change its width and height. Would you mind to explain more of how you cannot resize it?

Also, you can configure the pool to auto fit size so it will match its size with elements on it automatically. In order to enable this option, please right-click on the business process diagram (BPD) and select Presentation Options > Pool Display Options > Auto Stretch Pool in the popup menu.
Could you please try to enable this option and see if your printing issue can be solved?

If this does not solve your problem, would you mind to attach your project file for us to investigate? Thanks in advance!

Best regards,
Lilian Wong

Thanks Lilian for your prompt response.

I was able to fix the printing problem by turning off the Auto Stretch Pool option. The moment I turn it back on, the problem reappears. I at least have a work around now.

What are the grey bars that automatically appear both horizontal and vertical? They do not seem to do anything but get in the way of my grabbing the pool margin to resize it.

thanks in advance.


Hi FatherAntox,

Thanks for replying. The grey bars are for configuring diagram margin. It can help you to keep creating extra space on the right/at the bottom of diagram, which facilitates adding new models near the diagram edge. Please refer to the following link for details:


By the way, if you have configured to have wider margin (by the grey bar) on right hand side of diagram, and enabled “Auto Stretch Pool” option, you will find that the pool is always extended (base on the wide of margin you configured). I’m wondering if you have configured the diagram margin so you are not satisfactory with the printing result of the BPD unless you turn off the “Auto Stretch Pool” option.
If this is the case, setting to have narrower diagram margin or turn off the “Auto Stretch Pool” option will solve the problem. Should you have any further question, please feel free to ask.

Best regards,
Lilian Wong