SysML: cannot add block as a parameter of an operation

Create two SysML blocks A and B.
Add an operation to A (like myOperation).
Try to choose the B either as a return type, or as a type of the parameter in the dropdown (not possible).

Create a new class (C) in the model.
Repeat the previous steps but try to add C as a return type. Result: C will be displayed and selectable.

As a user i would like to add a block to an operation as a return type as well as as a parameter type.

Hi Zsolt,

Thank you for your post. We have tried to repeat the problem by following your steps but without success. Could you watch my video below and let me know if my steps are correct?

Best regards,
Jick Yeung

Hello, almost.

I created two blocks, A and B.
What I wanted is to add an operation to B, which has a parameter of the type A.
I created a new parameter, and tried to select the type as A, which was not in the list.
Then I selected a string, to see, that a type can be selected.
Then I added a new class named MyClass.
Then added a new parameter to the operation in B, and there I could select MyClass as a type, but sadly not A.

Attached a video to make things more clear. If you have any question, please feel free to ask, I am happy to help. Thank you!