Trouble starting the evaluation copy of Visual Paradigm for UML PE

First of all it isn’t obvious which script you need to start when you have installed the necessary files using the evaluation key. I’ve tried bin/"VP Suite"
and all it does is create a file called vp.log with the following message in it.

Start Visual Paradigm for UML Professional Edition [VP-UML PE]: 5.0 (20050624a)
Not running DB-VA or VP-UML using RV

At this point nothing happens. We have an older copy of Visual Paradigm and it starts without a hitch but it doesn’t allow you to reverse engineer anything but Java. I’m looking at a C++ program that I’d like to understand and hence I thought I would try the later version of Visual Paradigm

Any help would be most appreciated.

Tony Vasile

Dear Tony,

Thank you for your message. Could you mind tell me more details about your problem? What platform that you are working on? Are you using the installer or the no install version? Thanks in advance and I’m looking forward to hear your reply.

Best regards,

[quote=Rain]Dear Tony,

Thank you for your message. Could you mind tell me more details about your problem? What platform that you are working on? Are you using the installer or the no install version? Thanks in advance and I’m looking forward to hear your reply.

Best regards,

I’m trying to run on a Redhat 9 box on a PC. I thought I was using the installer version but I can’t find any documentation on what to do once the software is installed.

Any help would be most appreciated.


Tony Vasile

Dear Tony,

Thanks for your reply. There should have some shortcut(s) created automatically for launching the application. You can also launch it through the scripts inside the launcher directory of VP Suite (i.e. run_vpuml for launching VP-UML). For more information about the installation, please refer to the VP Suite User’s Guide.

VP Suite User’s Guide

Please feel free to contact us again if you have any further questions.

Best regards,

When I try the try the run_vmpl script nothing happens it seems to try and start a Java program and I get no output. I then get another vp.log file with the same error message as before, i.e " Not running DB-VA or VP-UML using RV" and then nothing.

I am most perplexed.

Tony Vasile

Dear Tony,

Could you please send me the vp.log file for investigation? You can send it to or through private message. Thanks in advance!

Best regards,

One line I missed out could be important. The first line is “Cannot read Product and Edition”. The rest of the file contains what was the same as my first message with the start date whatever the system clock is reporting.

I assume there is an incorrect configuration file somewhere in the installed product.


Tony Vasile

Dear Tony,

Could you mind tell me is there a file call “” inside the bin directory? If the file exist, could you mind send me the file for investigation? Thanks in advance!

Best regards,

The only file I have with that name is in the netbeans_sde/bin/sde directory.
Its contents are:

#Tue Jul 12 19:18:44 EST 2005

There is not other file installed with the name

Tony Vasile

Perhaps a different cause, but I can’t start either. Program exits while initializing models. here is the log file:

An unexpected error has been detected by HotSpot Virtual Machine:

EXCEPTION_ACCESS_VIOLATION (0xc0000005) at pc=0x7c910f29, pid=5784, tid=6048

Java VM: Java HotSpot™ Client VM (1.5.0_04-b05 mixed mode, sharing)

Problematic frame:

C [ntdll.dll+0x10f29]

--------------- T H R E A D ---------------

Current thread (0x009c1840): JavaThread “Thread-313” [_thread_in_native, id=6048]

siginfo: ExceptionCode=0xc0000005, reading address 0x00000003

EAX=0x05570d70, EBX=0x003d0000, ECX=0x00000003, EDX=0x00000001
ESP=0x06abf5e8, EBP=0x06abf5f4, ESI=0x05570d68, EDI=0x0556d6c8
EIP=0x7c910f29, EFLAGS=0x00010246

Top of Stack: (sp=0x06abf5e8)
0x06abf5e8: 003d0000 0556fbf8 00000000 06abf6c8
0x06abf5f8: 7c910d5c 055ea548 00000003 06abf6ac
0x06abf608: 00000000 055ea548 0556fc00 77c2c21b
0x06abf618: 045c0000 009ddeb8 0556d6c8 009ddf54
0x06abf628: 7ffa6000 50ff8001 7ffa6000 009ddf74
0x06abf638: 009ddfc4 50ff8001 00010000 00000000
0x06abf648: 00000000 00010000 06abf6ac 6d259a9c
0x06abf658: 06abf66c 00000001 0556f75c 0556f730

Instructions: (pc=0x7c910f29)
0x7c910f19: 85 92 00 00 00 8b 4e 0c 8d 46 08 8b 10 89 4d 0c
0x7c910f29: 8b 09 3b 4a 04 89 55 14 0f 85 ea 0f 00 00 3b c8

Stack: [0x068c0000,0x06ac0000), sp=0x06abf5e8, free space=2045k
Native frames: (J=compiled Java code, j=interpreted, Vv=VM code, C=native code)
C [ntdll.dll+0x10f29]
C [ntdll.dll+0x10d5c]
C [msvcrt.dll+0x1c2de]

Java frames: (J=compiled Java code, j=interpreted, Vv=VM code)
j sun.font.FileFont.getGlyphImage(JI)J+0
j sun.font.FileFontStrike.getGlyphImagePtr(I)J+62
j sun.font.FileFontStrike.getGlyphMetrics(I)Ljava/awt/geom/Point2D$Float;+25
j sun.font.StandardGlyphVector$GlyphStrike.addDefaultGlyphAdvance(ILjava/awt/geom/Point2D$Float;)V+5
j sun.font.StandardGlyphVector.initPositions()V+106
j sun.font.StandardGlyphVector.getLogicalBounds()Ljava/awt/geom/Rectangle2D;+5
j java.awt.Font.getStringBounds([CIILjava/awt/font/FontRenderContext;)Ljava/awt/geom/Rectangle2D;+168
j java.awt.Font.getStringBounds(Ljava/lang/String;Ljava/awt/font/FontRenderContext;)Ljava/awt/geom/Rectangle2D;+11
j java.awt.FontMetrics.getStringBounds(Ljava/lang/String;Ljava/awt/Graphics;)Ljava/awt/geom/Rectangle2D;+10
j v.bxi.i()V+56
v ~StubRoutines::call_stub

--------------- P R O C E S S ---------------

Java Threads: ( => current thread )
0x009da830 JavaThread “Timer-336” [_thread_blocked, id=2000]
=>0x009c1840 JavaThread “Thread-313” [_thread_in_native, id=6048]
0x009d06c0 JavaThread “TimerQueue” daemon [_thread_blocked, id=5096]
0x009bea90 JavaThread “Image Fetcher 2” daemon [_thread_blocked, id=4608]
0x009be4a0 JavaThread “Image Fetcher 1” daemon [_thread_blocked, id=4596]
0x009b7330 JavaThread “Thread-5” [_thread_blocked, id=4436]
0x009ae200 JavaThread “Image Fetcher 0” daemon [_thread_blocked, id=4416]
0x009ab1e0 JavaThread “com.jniwrapper.NativeResourceCollector” daemon [_thread_blocked, id=3092]
0x0098c790 JavaThread “Thread-2” [_thread_blocked, id=6072]
0x00987ad0 JavaThread “AWT-EventQueue-0” [_thread_blocked, id=6036]
0x00986640 JavaThread “AWT-Windows” daemon [_thread_in_native, id=6016]
0x00986100 JavaThread “AWT-Shutdown” [_thread_blocked, id=6012]
0x00985500 JavaThread “Java2D Disposer” daemon [_thread_blocked, id=6008]
0x0097d310 JavaThread “Low Memory Detector” daemon [_thread_blocked, id=5860]
0x0097c7f0 JavaThread “CompilerThread0” daemon [_thread_in_vm, id=5856]
0x0097c100 JavaThread “Signal Dispatcher” daemon [_thread_blocked, id=5852]
0x0097b2d0 JavaThread “Finalizer” daemon [_thread_blocked, id=5848]
0x0097ace0 JavaThread “Reference Handler” daemon [_thread_blocked, id=5844]
0x009732e0 JavaThread “main” [_thread_blocked, id=5788]

Other Threads:
0x0097a3e0 VMThread [id=5840]
0x0097edc0 WatcherThread [id=5872]

VM state:not at safepoint (normal execution)

VM Mutex/Monitor currently owned by a thread: ([mutex/lock_event])
[0x009727d0/0x0000006c] CodeCache_lock - owner thread: 0x0097c7f0
[0x00972ec0/0x00000164] MethodCompileQueue_lock - owner thread: 0x0097c7f0

def new generation total 9152K, used 3960K [0x06b90000, 0x07570000, 0x092f0000)
eden space 8192K, 37% used [0x06b90000, 0x06e8a100, 0x07390000)
from space 960K, 95% used [0x07480000, 0x075642c8, 0x07570000)
to space 960K, 0% used [0x07390000, 0x07390000, 0x07480000)
tenured generation total 121024K, used 9696K [0x092f0000, 0x10920000, 0x26b90000)
the space 121024K, 8% used [0x092f0000, 0x09c681b8, 0x09c68200, 0x10920000)
compacting perm gen total 13312K, used 13228K [0x26b90000, 0x27890000, 0x2ab90000)
the space 13312K, 99% used [0x26b90000, 0x2787b1c8, 0x2787b200, 0x27890000)
ro space 8192K, 62% used [0x2ab90000, 0x2b0993f0, 0x2b099400, 0x2b390000)
rw space 12288K, 46% used [0x2b390000, 0x2b91fe20, 0x2b920000, 0x2bf90000)

Dynamic libraries:
0x00400000 - 0x00432000 C:\Program Files\VP Suite 2.0\launcher\run_vpuml.exe
0x7c900000 - 0x7c9b0000 C:\WINDOWS\system32\ntdll.dll
0x7c800000 - 0x7c8f4000 C:\WINDOWS\system32\kernel32.dll
0x77dd0000 - 0x77e6b000 C:\WINDOWS\system32\ADVAPI32.DLL
0x77e70000 - 0x77f01000 C:\WINDOWS\system32\RPCRT4.dll
0x77f10000 - 0x77f56000 C:\WINDOWS\system32\GDI32.dll
0x77d40000 - 0x77dd0000 C:\WINDOWS\system32\USER32.dll
0x77c10000 - 0x77c68000 C:\WINDOWS\system32\msvcrt.dll
0x7c9c0000 - 0x7d1d4000 C:\WINDOWS\system32\SHELL32.DLL
0x77f60000 - 0x77fd6000 C:\WINDOWS\system32\SHLWAPI.dll
0x76390000 - 0x763ad000 C:\WINDOWS\system32\IMM32.DLL
0x629c0000 - 0x629c9000 C:\WINDOWS\system32\LPK.DLL
0x74d90000 - 0x74dfb000 C:\WINDOWS\system32\USP10.dll
0x773d0000 - 0x774d2000 C:\WINDOWS\WinSxS\x86_Microsoft.Windows.Common-Controls_6595b64144ccf1df_6.0.2600.2180_x-ww_a84f1ff9\comctl32.dll
0x5d090000 - 0x5d127000 C:\WINDOWS\system32\comctl32.dll
0x6d640000 - 0x6d7c9000 c:\progra~1\vpsuit~1.0\jre\bin\client\jvm.dll
0x76b40000 - 0x76b6d000 C:\WINDOWS\system32\WINMM.dll
0x6d280000 - 0x6d288000 c:\progra~1\vpsuit~1.0\jre\bin\hpi.dll
0x76bf0000 - 0x76bfb000 C:\WINDOWS\system32\PSAPI.DLL
0x6d610000 - 0x6d61c000 c:\progra~1\vpsuit~1.0\jre\bin\verify.dll
0x6d300000 - 0x6d31d000 c:\progra~1\vpsuit~1.0\jre\bin\java.dll
0x6d630000 - 0x6d63f000 c:\progra~1\vpsuit~1.0\jre\bin\zip.dll
0x6d000000 - 0x6d167000 C:\Program Files\VP Suite 2.0\jre\bin\awt.dll
0x73000000 - 0x73026000 C:\WINDOWS\system32\WINSPOOL.DRV
0x774e0000 - 0x7761d000 C:\WINDOWS\system32\ole32.dll
0x5ad70000 - 0x5ada8000 C:\WINDOWS\system32\uxtheme.dll
0x6d240000 - 0x6d27d000 C:\Program Files\VP Suite 2.0\jre\bin\fontmanager.dll
0x74720000 - 0x7476b000 C:\WINDOWS\system32\MSCTF.dll
0x755c0000 - 0x755ee000 C:\WINDOWS\system32\msctfime.ime
0x6d3c0000 - 0x6d3df000 C:\Program Files\VP Suite 2.0\jre\bin\jpeg.dll
0x6d190000 - 0x6d1bf000 C:\Program Files\VP Suite 2.0\jre\bin\cmm.dll
0x6d4c0000 - 0x6d4d3000 C:\Program Files\VP Suite 2.0\jre\bin\net.dll
0x71ab0000 - 0x71ac7000 C:\WINDOWS\system32\WS2_32.dll
0x71aa0000 - 0x71aa8000 C:\WINDOWS\system32\WS2HELP.dll
0x6d4e0000 - 0x6d4e9000 C:\Program Files\VP Suite 2.0\jre\bin\nio.dll
0x5b860000 - 0x5b8b4000 C:\WINDOWS\system32\netapi32.dll
0x01570000 - 0x01575000 C:\Program Files\VP Suite 2.0\bin\vp_windows\E1.dll
0x76b20000 - 0x76b31000 C:\WINDOWS\system32\ATL.DLL
0x77120000 - 0x771ac000 C:\WINDOWS\system32\OLEAUT32.dll
0x01580000 - 0x01585000 C:\Program Files\VP Suite 2.0\bin\vp_windows\I1.dll
0x01590000 - 0x01595000 C:\Program Files\VP Suite 2.0\bin\vp_windows\W1.dll
0x71a50000 - 0x71a8f000 C:\WINDOWS\System32\mswsock.dll
0x76f20000 - 0x76f47000 C:\WINDOWS\system32\DNSAPI.dll
0x76fb0000 - 0x76fb8000 C:\WINDOWS\System32\winrnr.dll
0x76f60000 - 0x76f8c000 C:\WINDOWS\system32\WLDAP32.dll
0x751d0000 - 0x751ee000 C:\WINDOWS\system32\wshbth.dll
0x77920000 - 0x77a13000 C:\WINDOWS\system32\SETUPAPI.dll
0x76fc0000 - 0x76fc6000 C:\WINDOWS\system32\rasadhlp.dll
0x05210000 - 0x0521a000 C:\Program Files\VP Suite 2.0\bin\vp_windows\jniwrap.dll
0x763b0000 - 0x763f9000 C:\WINDOWS\system32\COMDLG32.DLL
0x76840000 - 0x76873000 C:\WINDOWS\System32\spool\DRIVERS\W32X86\3\UNIDRVUI.DLL
0x778d0000 - 0x77913000 C:\WINDOWS\System32\spool\DRIVERS\W32X86\3\UNIDRV.DLL
0x05240000 - 0x052e7000 C:\WINDOWS\System32\spool\DRIVERS\W32X86\3\pcl5eres.dll
0x68280000 - 0x682a3000 C:\WINDOWS\System32\spool\DRIVERS\W32X86\3\hpcfont.dll

VM Arguments:
jvm_args: -Dexe4j.isInstall4j=true -Dexe4j.moduleName=c:\progra~1\vpsuit~1.0\launcher\run_vp~1.exe -Dexe4j.processCommFile=C:\DOCUME~1\SIMON~1.BLA\LOCALS~1\Temp\e4j_p5784.tmp -Dexe4j.tempDir= -Xmx512m -Xms128m -Dsun.java2d.noddraw=true

Environment Variables:
PATH=C:\Program Files\Microsoft SQL Server\90\Tools\Binn\VSShell\Common7\IDE;C:\Program Files\Microsoft SQL Server\90\DTS\Binn;C:\WINDOWS\system32;C:\WINDOWS;C:\WINDOWS\System32\Wbem;C:\Program Files\ATI Technologies\ATI Control Panel;C:\Program Files\Microsoft Office\OFFICE11\Business Contact Manager\IM;C:\Program Files\Microsoft SQL Server\80\Tools\Binn;C:\Program Files\Microsoft Office\OFFICE11\Business Contact Manager;c:\Program Files\Microsoft SQL Server\90\Tools\binn
PROCESSOR_IDENTIFIER=x86 Family 15 Model 4 Stepping 1, GenuineIntel

--------------- S Y S T E M ---------------

OS: Windows XP Build 2600 Service Pack 2

CPU:total 2 family 15, cmov, cx8, fxsr, mmx, sse, sse2, ht

Memory: 4k page, physical 916460k(299312k free), swap 2221452k(1550728k free)

vm_info: Java HotSpot™ Client VM (1.5.0_04-b05) for windows-x86, built on Jun 3 2005 02:10:41 by “java_re” with MS VC++ 6.0

Your problem could be caused by some fonts in your system which is not supported by the VM. Several users had report the similar problem (both on Windows & Linux). A user said that after he removed some fonts (tt-indic-fonts, ttf-malayam-fonts, xfonts-nexus) from his system then the software works. I have search through the Java bug database that some user already reported this problem to Sun, but didn’t find and information about which fonts are not supports. We are very sorry about that. I’ll let you know once we got more information about the font problem. If you have any further questions, please feel free to contact us again.

Best regards,

[quote=Anonymous]Perhaps a different cause, but I can’t start either. Program exits while initializing models. here is the log file:

So I have no idea how to remove fonts associated with Java. A Google search hasn’t given me much help.

I suggest you can try to replace the JRE inside VP Suite with a 1.4 version. This may help to solve the problem.

Best regards,

[quote=Rain]I suggest you can try to replace the JRE inside VP Suite with a 1.4 version. This may help to solve the problem.

Best regards,
thanks ! my problem solve ^^ ! i replace JRE inside VP Suite with a 1.6 version ( the version that i install in my computer)