Visual Paradigm crashes on fedora 36

Hi all,
after fedora 35 update to version 36 Visual Paradigm stopped running.
I decided to install VP on a newly installed fedora 36 and the problem persists.
Maybe someone can help me?

A fatal error has been detected by the Java Runtime Environment:

SIGSEGV (0xb) at pc=0x00007fe400637f7e, pid=51776, tid=51802

JRE version: OpenJDK Runtime Environment AdoptOpenJDK (11.0.10+9) (build 11.0.10+9)

Java VM: OpenJDK 64-Bit Server VM AdoptOpenJDK (11.0.10+9, mixed mode, tiered, compressed oops, g1 gc, linux-amd64)

Problematic frame:

C [] hb_font_get_font_v_extents_default(hb_font_t*, void*, hb_font_extents_t*, void*)+0xe

Core dump will be written. Default location: Core dumps may be processed with “/usr/lib/systemd/systemd-coredump %P %u %g %s %t %c %h” (or dumping to /home/administrator/Scaricati/

An error report file with more information is saved as:


If you would like to submit a bug report, please visit:

Issues · adoptium/adoptium-support · GitHub

The crash happened outside the Java Virtual Machine in native code.

See problematic frame for where to report the bug.

./ riga 594: 51776 Annullato (core dump creato) $INSTALL4J_JAVA_PREFIX “$app_java_home/bin/java” -Dexe4j.moduleName="$prg_dir/$progname" -Dexe4j.totalDataLength=761379330 -Dinstall4j.cwd="$old_pwd" “-Dsun.java2d.noddraw=true” $INSTALL4J_ADD_VM_PARAMS -classpath “$local_classpath” install4j.Installer647934017 “$@”

Hi Massimiliano_Tarquin,

Thank you for your post. We would like to gather more details from you to track down the issue. Could you submit a support request at the URL below, with a description of the issue and your log file?

How to obtain the log file:

Best regards,
Jick Yeung

Hi Jick, i already contacted VP support providing all they need to check for the problem.
Nevertheless, i’m still waiting for a feedback.
Honestly, it is starting being a problem for me.


Hi Max,

Sorry for my late reply. As I know, the problem has already been solved. If you have any other questions, please feel free to contact us again.

Best regards,
Jick Yeung

Hi Max,

By my record your problem was already solved by our support team. BTW for user who experienced similar problem can reference to article below about the solution. Feel free to contact us for any help and wish you have a good day!

Best regards,
Rain Wong