Visual Studio plugin problems - cannot revive project

I would need some help, as we are new to VP in visual studio in our company.
I made already few usfull diagrams within VS but after changing the project name VP project doesn’t show diagrams in VS anymore. When I open the *.vpp file in standalone app - all diagrams are visible and accessible, but we need it integrated into VS.

We are using VS 2017 Community. If anyone could help please be my quest, if you need more info, ask.

Cheers

hi jsw,

Do you mean rename the visual studio project name? I tried but cannot reproduce the problem, could you provide more details on the steps?
Do you mean no diagrams found in Diagram Navigator?
Can you show me the file list of vpproject folder under project folder?

1 Like

Hi Kit.So

The name change was to the assembly project name - our C# solution is made of few projects/assemblies. VP project was named after first assembly but I had to remove/rename it and replace it with a new one. After that in diagram navigator I see no diagrams.

In terms of file list in vpproject folder, sure I can show you but when I was trying to fix the problem I removed all files and replaced the *.vpp file with the one from the backup.

here is the file list (VP is creating new *.vpp file for the unit test assembly which is nothing we desire)
https://i.ibb.co/8z6QzJm/2019-12-13-07-35-52-vpproject.png

Hi jsw,

Sorry that I don’t understand what you mean, do you mean you renamed the vpp file?
There should be only 1 vpp file in vpproject folder, I found there are 2 vpp files which is abnormal…

Can you provide a list of steps to reproduce the problem from stretch?

1 Like

What I meant is that I had to rename first assembly - vpp files are named in visual studio after main assembly - after I changed the name of that assembly new vpp file was created and there is no way to create new diagrams nor see the old ones.

Hi jsw,

We found an issue on diagram navigator cause it cannot show diagrams, we’re working on the fix.
If the problem exists on new project without rename, please wait for a patch and skip the rest of this post.

The vpp file is depends on project name.
I tried rename assembly but cannot reproduce the problem.
And I tried rename project, open VP will prompt a dialog to select vpp file:
Screenshot
It’ll let you associate project with the previous vpp file.

But from your screenshot, I found you’re using teamwork. If you committed all your changes, you may follow these steps to re-checkout project from server:

  1. restart VS
  2. delete vpproject folder
  3. right click on project -> Visual Paradigm Project -> Open Teamwork Client…
  4. select your project and click Open or Force Open
1 Like

Great! Thank you - I will wait for the patch.

I would like to let you know the VS integration problem has been fixed. Please update the software to latest patch build (20191260bq or later) to get the problem fixed. Details about update to latest patch can be found at

  • Please make sure you have pressed the “Update to latest patch” button on the left hand side of the dialog right after launching the update program

Feel free to contact me if you require any further information.

1 Like

@Rain @Kit.So you rock guys! This bug was preventing us from buying few licensies but now I can see my old diagrams and can create new without a problem so we buy. I could also easily and simply recover my older project so nothing was lost.

One more time, thanks!

1 Like