VP hangs while saving

2 out of 5 times, when I press “save” on VP 16.3, I get a rotating wheel that spins forever and the program becomes totally unresponsive, so all I can do is kill the process.
This happens both to a M1 and an Intel i7 Mac

  • Context 1: Macbook Pro M1 (2020), 16 GB RAM, Macos Monterey 12.01
  • Context 2: iMac i7 (2018), 40 GB RAM, Macos Monterey 12.2

The good news is that autosave works!
The bad news is that I need to reset the floating license every time, which is really annoying…



I had a similar bug, which was solved in latest VP.


Thanks for the reply. Unfortunately this has been happening for a couple of updates back, and the thing is that it seems to be worse with the latest update.

What is most annoying is that I cannot link it to the M1, it happens all the same with my Intel Mac.

Let’s see what the VP people will say…

Thanks again,


1 Like

Did you tried to alter the vplauncher.vmoptions properties setting? I am working on windows/intel and experiencing the same issue, but after that change, it totally vanished. The symptoms were the same, during save the application froze, and only a task kill solved the problem.

Can you please let me know how do I do that?




I don’t own a Mac, so that’s what I found on the internet, but the file location is the following:

~/Library/Application Support/VisualParadigm/vplauncher.vmoptions

This is a text file, you can edit with a text editor. Open it, and add the following line at the end of the file in a new line:


Then start visual paradigm, and let’s see what happens. Probably should try it out with a test model, and not the real system.