Why shortcut doesn't work

Why the shortcut doesn’t work sometimes.

I’m using VisualParadigm 16.3, mac bigsur. I found sometimes new attributes(option+shift+A) doesn’t work. and after reboot the app, it will work again. but you don’t know when it will failed to work.

I tried define another shortcut, but the problem is still there.

Please help the fix it.

Hi meixuesong,

Thank you for your inquiry. Could you send us your log file to take a look? You can export log file from the About window (Help > About). Then, please upload the exported zip file to:
Password: kjbrfugf0nbjdfr34

Look forward to hearing from you.

Best regards,
Jick Yeung

Thanks for your reply.

I tried to upload the log, but it always shows uploading. so I upload it here: https://mxs-1256616343.cos.ap-chengdu.myqcloud.com/1629424158.88vp_16.3.zip

Hi meixuesong,

Thank you for your log file. The log looks fine and unfortunately, we are unable to repeat the problem on our Macs… Do you recall what you have done right before the problem occurred?

Best regards,
Jick Yeung

I can reproduce this issue, but don’t know why.

I upload a new log file. you can see:
16:42. I open VP
I create a class, and create new attribute through shortcut. it works.
I just create 3 attributes, move the class.
then I leave and work on other app.

17:36: I return to VP, and found the shortcut doesn’t work. you can see the NullPointerException

BTW. this happened in my old MBP. and also happened in my new MBP.

new log file: https://mxs-1256616343.cos.ap-chengdu.myqcloud.com/1629452464.59vp_16.3.2.zip

[2021/08/20 16:42:27] [message] Open Project “/Users/meixuesong/Documents/VPProjects/分析模式.vpp”, Time Used: 3 seconds, Memory: 256.0 MB (268435456), Project File Size: 3.07 MB (3222528), Diagram Count: 4
[2021/08/20 17:36:13] [message] java.lang.NullPointerException

Hi meixuesong,

Thank you for your file. I have forwarded it to our team for further checking. When there is any news, I will let you know.

Best regards,
Jick Yeung