Wrong generating SQL for PostgreSQL

Hi,

there’s some issue with generating SQL for PostgreSQL DB.
The issue is that all names (table names, column names) are not in quotes.

Please take a look at attached screenshot.

Fixing issue consist in quote ALL names, as it require PostgreSQL, otherwise table will be create with wrong name (for example with lowercase) or doesn’t create at all.

Please, check out with PostgreSQL Documentation.

Thanks,

issue-generate-pgsql.png

Hi Industral,

Thanks for your post and we are sorry about the problem. I’ve forwarded the issue to our engineers to follow-up, and I’ll get back to you once there is any feedback.

Best regards,
Lilian Wong

Hi Industral,

Please select Yes for Quote SQL Identifier at Tools > Options > ORM > General (as shown as image), then you will get the SQL script with quoted table/column names. If you have any further question, please let me know.

Best regards,
Lilian Wong

yes_for_quote_sql_identifier.png

Thanks, it works good for me.

Hi Industral,

That’s good! :smiley:

Best regards,
Lilian Wong