XMI import from Together fails with warnings

I tried to import a XMI file ( exported from Together) and it gave ton of warnings. But none of the diagrams were imported. All the warnings have the same kind of message “Control file is deleted”

[warning 03:54:40] ControlFlow link: StartState1 -> Is the a static table does not allow set To model to Is the a static table. (ControlFlow is deleted)
Model: link: StartState1 -> Is the a static table
From: StartState1 To: Is the a static table
XML Segment:

<UML:Transition isSpecification="false" name="link: StartState1 -> Is the a static table" source="G.18" target="G.21" visibility="package" xmi.id="G.17">
		<UML:ActionSequence isAsynchronous="false" isSpecification="false" name="" visibility="public" xmi.id="XX.65">
				<UML:IterationExpression body="" language=""/>
				<UML:ObjectSetExpression body="" language=""/>
				<UML:ActionExpression body="" language=""/>

Hi askmahesh,

Could you provide us with your XMI file for testing this problem? Different vendors support XMI in different ways, which might cause problem when importing an XMI to another product. But we will try to support as much as possible.

Best regards,

Hi askmahesh,

We’ve received your XMI. We’ve found that the XMI file does not contain any information about diagram. Could you check if there is anything wrong with the export process?

Best regards,


Thanks for your response. You are right . I used the Export to XMI (in Together) with XMI 1.1 for UML 1.4 ( OMG) . It seems that the OMG XMI does not include diagram information.

I had to use XMI 1.1 for UML 1.3 (UNYSIS Extension) and the import worked in VP-UML .


That’s great! :smiley: :smiley: