Error launching when activate VP


#1

Hello,

Excuse my bad English.
I’m on Mac OS X 10.13.
I’ve install Visual Paradigm CE in Application and when I launch activation, I’ve this error message :
“sun.security.ValidatorException: PKIK path building failed : sun.security.provider.certpath.SunCertPathBuilderException : unable to find valid certification path to requested target.”

what can I do to correct the error please ?

Thank you
Have a good day


#2

I don’t think there’s much you can do right now.

I am aware that Visual Paradigm (the company) is in the process of performing maintenance on their certificates, however it seems highly unlikely to me that this would affect the software in such a direct way.

Just make sure you got the latest release of the CE edition (when in doubt maybe download and install it again). In the mean time I grabbed a copy as well and I’ll see if I can reproduce these problems. If so then I’ll report them to VP directly including debug information.

PS (edit): Also make sure that your OS is fully up to date, especially things such as security certificates. Most operating systems update those from time to time, and if you haven’t then that could be a possible cause for your problems as well.


#3

As promised I just gave this a try myself and I cannot reproduce your problems, even though I am on Windows myself.

Therefor my suggestion is that you make sure to update your OS and apply all the available security updates. Look out especially for updates which involve the certificate store.

Hope this can help.