High CPU consumption on MacOS


On MacOS 12.0.1, VP consumes and gets stuck after a few minutes of use.
I increased the memory setting but nothing changed.
The previous version was working well.

Here the version I use:
VP Modeler
Version 16.3 (Build 20211215)

Here a screenshot of the CPU consumption:

Do you have any idea to solve this issue ?

Thank you,

Would you please try follow the article below to collect VP’s JVM thread dump and send us for checking? You can send it support@visual-paradigm.com in case you don’t want to upload it to forum. Thanks and look forward to hearing from you.


Here the thread dump as requested:
dump.log (26.6 KB)

Thank you for your help.

I updated VP to the latest patch (20211237): Visual Paradigm 16.3 ChangeLogs - #4 by Rain

The issue is still present.
It happens after save button click (but not always) or after diagrams switching.

Kind Regards,

I did some tests and it appears that if I cut the network off (Wifi off), VP works well. There is no more CPU overloads nor application hang up.

Maybe this can help you to figure out what’s going on.

Kind Regards,

Hi stondini,
Thank you for your posting. It helped me a lot. I have the same issue on a Windows 10.

Thanks for the details and our engineers are checking on it. Please be patient and will keep you post.

According to our engineers this problem should already fixed in our latest build 20220101. Please update the software to latest build to get it fixed. You can run the Visual Paradigm Update under Help menu to perform software update. Feel free to contact us for any help.


The issue is still present on build 20220101.

Thank you

Let me check.

Would you please try reinstall the software with the installer below and see will it works?

The installation package you’ve mentioned doesn’t start on my Mac (macos 12.0.1).
But, I downloaded VP 16.2 and updated it using the update feature.

I will instensively use VP the upcoming days. Keep you informed.

Thank you,

May I know what is the error message you got when you fail to run with the installer I sent you?

Of course.

In folder

/Volumes/Visual Paradigm/Visual Paradigm.app/Contents/MacOS

I ran the following command:

Error occurred during initialization of VM
Could not find agent library jdwp on the library path, with error: dlopen(libjdwp.dylib, 0x0001): tried: '/Volumes/Visual Paradigm/Visual Paradigm.app/Contents/Resources/jre.bundle/Contents/Home/lib/server/./libjdwp.dylib' (no such file), '/Volumes/Visual Paradigm/Visual Paradigm.app/Contents/Resources/jre.bundle/Contents/Home/lib/server/../libjdwp.dylib' (no such file), 'libjdwp.dylib' (no such file), '/usr/local/lib/libjdwp.dylib' (no such file), '/usr/lib/libjdwp.dylib' (no such file), '/Volumes/Visual Paradigm/Visual Paradigm.app/Contents/Resources/app/bin/libjdwp.dylib' (no such file), '/usr/local/lib/libjdwp.dylib' (no such file), '/usr/lib/libjdwp.dylib' (no such file)

Here the content of the folder:

/Volumes/Visual Paradigm/Visual Paradigm.app/Contents/Resources/jre.bundle/Contents/Home/lib/server
drwxrwxr-x   5 sto  staff       170 Jan 10 12:21 .
drwxrwxr-x  59 sto  staff      2006 Jan 10 12:21 ..
-rw-rw-r--   1 sto  staff      1322 Jan 10 12:21 Xusage.txt
-rw-rw-r--   1 sto  staff     50096 Jan 10 12:21 libjsig.dylib
-rw-rw-r--   1 sto  staff  14359264 Jan 10 12:21 libjvm.dylib

There is no libjdwp.dylib file.

Hi Rain,
So, after a few days using re-installed VP, I haven’t faced the high CPU consumption.

Hi stondini,

Thank you for your inquiry. We are glad to know that the problem is solved.

Best regards,
Jick Yeung