How do we suppress text "preview"?


#1

I’m sure there is going to be a trivial solution to this buried in the options but I haven’t been able to find it.

I use extensive notes throughout my modelling. When editing them, the major irritant is that VP insists on previewing the content (why? It’s there in front of me!!) which, with a large note essentially entails a “tooltip” type preview which completely blocks that note I’m working on and makes it extremely awkward to edit.

How do we switch that behaviour off? and I mean permanently, throughout the model, not just ad hoc for a particular object or drawing. I genuinely haven’t encountered a single occasion when that preview has been anything but annoying.


#2

Just making sure I understand the issue correctly: are we talking about note model elements, the same ones found within the UML specification?

Because I can’t reproduce anything such as a preview:

This is what I get to see when I double click on the note model element to edit it. No previews, only the text as I’m about to edit it.

So… could you elaborate a bit more on this?


#3

a picture paints a thousand words. Here is an example of the first pointless preview (the text box Unselected)

and in this one, as you can see from the grab handles, the text box is now selected, but we still get the pointless preview…

(edit)
I should make it clear that I agree with your description of behaviour on doubleclick (as if you’re editing the whole piece) but that’s rarely my use case. I raised a number of issues in my early days with the editor (particularly the bizarre behaviour of the action taking place some random number of spaces left of the cursor) These were never resolved so I never edit more than a spelling mistake or single word in situ. If I need to edit more dramatically (eg insert or delete a sentence) I always cut and paste the text into a more stable text editor, do the edit then copy and paste back into the VP object.

There are two scenarios where the pointless previews are really irritating. One is probably common, the need to edit a single word and the mouse tracking to that word is suddenly obscured by a the giant preview. The second is probably unique to me as it’s a requirement for my html modelling. The devs made some significant improvements following my nagging at the tail end of last year, but they never cracked the main issue (preventing the html glossary links opening one new window per link) and so I’m still using our home grown solution to that (pasting hot spots over the links so we can recode the output html to use our window structure rather than VPs) That pasting does not require “editing” the text. In fact, that would make it impossible. So what typically happens is that I’m dragging a hot spot (an oval with the required link buried in it) over the glossary link, when suddenly the preview obscures the target and I cannot complete the task (accurately)

I accept that this is a unique situation but my wider point still holds. In about 3,000 hours of using VP I have yet to hit a single situation where those previews are remotely useful. I imagine they must be for other users but not for me. Please! Just tell me how to switch them off!!


#4

And this is exactly why I asked; within the field of Tech details are very important. You mentioned a Note element in the main post but obviously referred to a textbox. Details like that can be very important and if you made the same mistakes with any bug reports then I can easily understand why they never got any follow up: reproducing any issues would result in nothing.

However…

[snip]

But how come?

See: the only way to edit the text in a textbox is by entering edit mode (double click), in which there won’t be any previews. This also applies when you want to copy (parts of) the text: you can’t open any specifications nor can you simply use a copy option because that would copy the entire model element as-is (so: the text box and not necessarily the actual text).

So the only way to copy the text would be to enter edit mode, select all, copy and then paste that in an external editor. However… that wouldn’t trigger any previews because those are not enabled during edit mode.

As such I don’t understand how the previews would be bothering you because these only occur when you’re not editing. (edit): See mouse tracking is a bit pointless if you’re not editing because you can’t select & copy text this way: clicking would select (and move) the entire text box.


#5

As such I don’t understand how the previews would be bothering you

although I’m interested in your opinion, it isn’t really relevant to my question. There is no need to get into the pros and cons of previews. As I conceded in my previous, other users might find them useful (and unobtrusive). Good for them. I don’t. My question is simply: “Can I turn the previews off, and, if so, how?”


#6

Not as far as I know, no.


#7

Hi Harry,

Just look up “tooltip” in the Application Options dialog box and uncheck Show diagram element tooltip will turn off tooltips for all diagram elements.

Hope this helps,

Antony.


#8

Brilliant!

Thankyou Antony, that worked perfectly.

I knew (if it existed) it would be simple. Very well buried though. For anyone wishing to follow in my footsteps the exact (menu) path to the option is:
\Tools\Application Options\Diagramming\Environment(tab)
That’ll get you to the page Antony displays above.

Cheers