Is it possible to disable snapping only for labels?


#1

Hello,

I like the snapping feature in the class diagraù, but sometimes, when elements are tight, the link labels hide (partially or totally) the elements around. It cold be located at a better place, but I have to disable snapping. But I want to keep it for the classes and links.


#2

You can probably resolve that with the option “paint through labels”. If you have a connector selected then right click and find the menu entry “Presentation Options”. It will have a section called “Paint through label” which basically determines if the label(s) should blank out other elements or if those should be painted through. It’s often quite useful to turn this on, because a label consists of both the text and the box surrounding it.

You’re talking about the ‘Snap to grid’ option I assume? As far as I know that’s a global setting, so it applies to all elements in your diagram.

Hope this can help.


#3

Yes, the problem is that I can’t disable labels snapping…


#4

Gotcha. Well, there isn’t a full proof solution here because once you turn on “snap to grid” then this applies to all diagram entries (model elements, labels, etc.). But I did discover somewhat of a work around which might be useful for you…

You can assign key combinations to many functions within VP, so why not assign Alt-S to the function “snap to grid” so that you can turn this on and off without having to click on any icons in your toolbar? Could that help make things easier?

Here’s how you can do that:

  • Go to the ‘Window’ tab and select “Application Options”.
  • Click on ‘Keys’ and in the search bar (right side of the window) type in: “snap” (without the quotes obviously).
  • Click on “Snap to Grid”, then click on the box behind ‘Binding’ (seen at the bottom) and after you did that press alt + s on your keyboard (alt, and then the s key).
  • The Binding box should now say ‘Alt+S’ and it should not list any conflicts.
  • Click “Ok” or "Apply"and then “Ok”.
  • Restart the application.

After this you should have Alt-S assigned to ‘snap to grid’; so every time you work on a label you can simply press alt-s, then position your label, and press alt-s again to turn snapping back on.

(edit):

Of course, the down side to this is that once you turn “snap to grid” back on then the labels will snap into position again. Still, it might be less annoying because you did have the chance to roughly place them in the right spot.

Maybe also good to know: you could also consider changing the grid size. I have no idea if this will help, but… By default the grid is set to 10 x 10, maybe making the grid somewhat smaller might help…

You can do this in two ways; either go to the application options (as explained above) and select the ‘Diagramming’ section. The Appearance tab shows you the grid settings. The other way is to right click somewhere in your diagram, find ‘Presentation Options’ in the menu, then ‘Grid’ and there you’ll find ‘Grid settings’.

I know this doesn’t immediately solve your problem, but I still hope it can help a bit.