[Problem] Stack on splash screen on startup


#1

Hello,

We are running v14.2of the program.
When starting the program, its stuck on the splash screen (Says Initializing Environment)
We tried to start the program in different workspace but we get the same issue.

We cant use the updater because its been blocked by our proxy.

Our IT checked logs (I’ve pasted it below), and they say that the Java is not trusted on the certificate of out proxy server. We have have put it on trusted and still the program wouldn’t start.

I couldn’t put here the log because all the links inside so here is a link to the logs I get (Its inside the HTML window):

Please help with the issue.

Thanks,
Andrei


#2

Solely judging from the error message the problem seems to be fully client sided, and I know that the Visual Paradigm company has changed their certificate earlier this year. I don’t know all the details of course, but it could be related. Unfortunately I don’t have access to version 14.2 myself, but I think I might have a solution.

See: by default VP will check the Internet to see if there are any program updates as well as news updates. Considering that this is blocked by your proxy it might make more sense to turn that behavior off. Normally you’d do this from within Visual Paradigm, but I know of another way too :wink:

First: find the current VP workspace, this is important. Inside that directory you should find a sub directory called .vpprefdata:

Inside that directory you should find a file called .vp.preference. Try to open that with a text editor (like Notepad or Metapad). Make sure that VP isn’t running!

Now, you’ll see a lot of XML data, these are the options you need to find:

<AutoUpdate value="0"></AutoUpdate><NewsFeedPeriod value="2"></NewsFeedPeriod>

You should be able to find these values near the top. Actually the lower half of the first page, but that obviously depends on your editor size and resolution and such. But to give you an impression:

You will most likely have different values than me. Change both values to 0 (which means that VP won’t check for any updates for software and news), then save the file and try to start VP again.

As mentioned before: make sure that you use the right workspace!

Hope this can help.


#3

Hi ShelLuser.

First, I’ve tried what you said, and it didn’t help.
Also, from the Java logs, I understand that it doens’t gets blocked per se.
It just doesn’t work because the proxy certificate (it’s my company’s proxy) is not trusted by Java.
I’ve tried adding the root certificate of the proxy to the user cert store in the Java control panel, but it didn’t help.

Any suggestions?

Thanks,
Andrei.