Problems with TeamworkService

Hello,

I have send the problem description few days ago and the topic is not visible. Is there anything I shall know for the post to be published ?

Best regards, Artur

Hi Artur,

Thanks for your post. Maybe your pending post was deleted mistakenly… I’m sorry about this.

Would you mind to tell me details of your problem once again? Thanks!

Best regards,
Lilian Wong

Hi Lilian,

It looks my post from today was delete again.

As promised, please find the teamwork_admin_config

Execute cmd: cmd.exe, /C, E:\Development\Teamwork Server 4.0\bin\StartTeamworkServer.exe,
env: null
NativeExecute-0 (in): Error occurred during initialization of VM
NativeExecute-0 (in): Could not reserve enough space for object heap
Execute cmd: cmd.exe, /C, E:\Development\Teamwork Server 4.0\bin\StartTeamworkServer.exe,
env: null
NativeExecute-1 (in): Error occurred during initialization of VM
NativeExecute-1 (in): Could not reserve enough space for object heap
Execute cmd: cmd.exe, /C, E:\Development\Teamwork Server 4.0\bin\StartTeamworkServer.exe,
env: null
NativeExecute-2 (in): Error occurred during initialization of VM
NativeExecute-2 (in): Could not reserve enough space for object heap

and the error description:

[i]Started executable E:\Development\TeamworkServer\bin\StartTeamworkServer.exe at Fri Apr 24 10:28:24 2009

number of sections: 5
size of optional headers: 224
resSectionTableStart: 536
rawDataSize: 18944, rawDataOffset: 136192
extracting files
Included files: 0
delete queue L-CHAN_FU_WAH_EDISON#846015600010001-1aslnef1dqn2i4#111
emptying L-CHAN_FU_WAH_EDISON#846015600010001-1aslnef1dqn2i4#111
delete dir L-CHAN_FU_WAH_EDISON#846015600010001-1aslnef1dqn2i4#111
LoadDLL (1, (null), 0)
Searching for a JVM
Has preferred location E:\Development\TeamworkServer\jre
checkJavaExe (e:\development\teamworkserver\jre\bin\java.exe, [out], 1.4, , 1)
file exists
got version from registry 1.5.0_12
Using preferred location
Trying to load JVM-DLL from e:\development\teamworkserver\jre\bin\javaw.exe
Setting PATH C:\oracle\product\10.2.0\db_1\bin;C:\WINDOWS\system32;C:\WINDOWS;C:\WINDOWS\System32\Wbem;C:\Program Files\Microsoft SQL Server\80\Tools\Binn;C:\Program Files\Microsoft SQL Server\90\DTS\Binn;C:\Program Files\Microsoft SQL Server\90\Tools\binn;C:\Program Files\Microsoft SQL Server\90\Tools\Binn\VSShell\Common7\IDE;C:\Program Files\Microsoft Visual Studio 8\Common7\IDE\PrivateAssemblies;c:\php;e:\development\teamworkserver\jre\bin
Trying e:\development\teamworkserver\jre\bin\hotspot\jvm.dll (exists 0)
Trying e:\development\teamworkserver\jre\bin\client\jvm.dll (exists 1)
Loading of JVM-DLL successful
launching program
vmoption count 9
vmoption 0: -Dexe4j.isInstall4j=true
vmoption 1: -Dexe4j.moduleName=E:\Development\TeamworkServer\bin\StartTeamworkServer.exe
vmoption 2: -Dexe4j.tempDir=
vmoption 3: -Dexe4j.unextractedPosition=0
vmoption 4: -Dexe4j.consoleCodepage=cp0
vmoption 5: -Xmx1024m
vmoption 6: -Xms128m
vmoption 7: -Djava.awt.headless=true
vmoption 8: -Djava.class.path=E:\Development\TeamworkServer.install4j\i4jruntime.jar;E:\Development\TeamworkServer\bin…\lib\platforminstaller.jar;
Creating JVM
ERROR: could not initialize JVM[/i]

Best regards, Artur

Hi Lilian,

We cannot start the Teamwork service as it clamis tham JVM cannot be started, or thrown an exception. I’ll be able - if it is necessary - send you detailed description of the exception as well as admin_log later on today.

Best regards, Artur

Hi Artur,

Thanks for your reply (BTW, your last 2 posts are published in wrong order during approving the messages - SORRY!). We will check the moderate messages in forum several times every working day, so you may not see your post being published before this.
But your original post about your problem in Teamwork Server should be really deleted mistakenly. Sorry about this!

Let’s get back to your Teamwork Server problem. May I know are you using Window Vista?
And did you restart the machine after installed the Teamwork Server as service?

Best regards,
Lilian Wong

Hi Lillian,

We’re using Windows Server 2003 and it was restarted after the installation.

Best regards, Artur

Hi Artur,

Thanks for replying. May I know after restarted the machine, did the Teamwork Server service startup automatically?

Could you please attach the vp.log file (inside TeamworkServer/jetty/webapps/vpteamwork/WEB-INF) for me to take a look? Thanks in advance!

Best regards,
Lilian Wong

Hi Lilian,

Please find the file.

Best regards, Artur
vp.log

Hi Artur,

Thanks for replying with the log file. From the log file you are running Teamwork Server 3.4, but in your 2nd post it shows it’s Teamwork Server 4.0. May I know which version of Teamwork Server did you installed?

Also, could you please capture a screenshot of the About dialog of your VP client for me to take a look? Thanks in advance!

Best regards,
Lilian Wong

Hi Lilian,

We have installed 4.0 over the 3.4.

I’ll be able to provide you with the screenshot on Monday.

Best regards, Artur

Hi Artur,

Thanks for replying. I’ve forwarded this issue to our online ticket system (http://support.visual-paradigm.com/). If you do not receive my email sent from support-team@visual-paradigm.com, it is possible that the security settings of your email program are preventing our email from being delivered to you. Please find it from the junk or trash folders.

Best regards,
Lilian Wong

Hi Lilian,

Please find the screenshot.

Best regards, Artur

VPAbout.jpg

Hi Lilian,

As for the e-mail, I did nor receive any. May I ask you to re-send it ?

Thank you in advance, Artur

P.S. By the way, may I ask to provide us with VP/TS licenses for version 4.x ?

Hi Artur,

Thanks for replying. I’ve resent my message in out online ticket system, I also reply your question about license in my message.
If you cannot get my email , please try to find my email from trash and junk box.

Best regards,
Lilian Wong

Hi all,

Just a note: we resolved this issue in online ticket system already.

Best regards,
Lilian Wong

Hi,

What is the solution ? we have exactly the same trouble with TeamWork and a Windows Server 2003 that has just been updated.

We cannot use it anymore for now one week !

Hi Arnaud,

Thanks for your post. I just sent you a ticket to follow-up your problem from our online ticket system and you should receive my email soon. Hope we can receive your reply soon.

Best regards,
Lilian Wong

I cannot have direct access to the TemaWork server (due to security policies).

When we try to start the ServiceNT we have the folowing message (JVM cannot start or something like that).

I have demands from many people to repair the TeamWork server each day…

We have exactly the same trouble with TeamWork Serveur 1.4 on Windows 2003 Server. This has happen after an update of the server.

Is there a way to correct this (quickly).

Hi Arnaud, users,

Thanks for your post. We experienced that user’s Windows 2003 Server cannot access heap size by -Xmx1024m (default). Please try:

  1. go to $teamwork_server_installation_directory/bin folder
  2. create a file “start.properties” in the folder
  3. edit the file and enter:
    Xms=256m
    Xmx=768m
  4. save the file
  5. restart the service of Teamwork Server (Control Panel > Administration Tools > Services)

If this does not work, please try to change to Xmx=512m in step 3 and try again. We do hope this can help solving the problem.

Best regards,
Lilian Wong