Send Signal/Receive Signal in User Guide, not in 2.3.0



I was wondering about the availability of Send Signal and Receive Signal in Activity Diagrams with version 2.3.0, since they appear in the User Guide.Does anyone know why these items appear in the User Guide but not on the toolbar for Activity Diagrams? If the features are not implemented, does anyone have a workaround and Case study example for an Activity Diagrams? If the features are not implemented, is there a timeline for including them? Please help me out.

Any help will be appreciated.
Thank you


Hi Aaron, if you expand the Action button in the toolbar by click and hold the mouse button, you should be able to select various kind of actions you need as in screenshot.


Hope this helps,



Are you sure you don’t mean version 12.3 or similar? Because 2.3 would be really old :wink:

I’d like to mention another very useful way to do this: just double click on an empty area in your diagram. This will bring up the so called Resource Catalog which will show you all the available relevant model elements for the current diagram you’re working on. So the initial and final nodes, decision and fork nodes and all available action types.

Note that you can also use the resource catalog by clicking on an element (it will be shown in the upper right corner) and then dragging it to the location where you want your new (connected) model element to be placed.

Hope that this can also help.


Thanks ShelLuser, I should have taught the resource catalog method instead but I simply forget about this option! It is preferred because all elements are flatten and presented with larger icons so you can find the desired element easier. And you can click on an element to create it at the double-clicked location immediately.

If you don’t see the resource catalog when double-click on diagram, you probably still using the classic resource-centric interface. You can learn how to switch to the resource catalog interface here.


Hi, I think Aaron is talking about UML 2.3. :thinking:


You’re absolutely right, I need more coffee :coffee: