Vp stuck when startup


#1

I am trying for VP evaluation for days, but today VP failed to start.
I tried to reinstall VP, but it doesn’t work.

here are logs from vp.log

[2017/06/10 13:19:31] [message] Operating system: Mac OS X 10.12.5 running on x86_64
[2017/06/10 13:19:31] [message] Java VM: 1.8.0_121 Java HotSpot™ 64-Bit Server VM, vendor 25.121-b13 Oracle Corporation
[2017/06/10 13:19:31] [message] User: cool, language: zh
[2017/06/10 13:19:31] [message] Installation ID: 185d2d648daac684f2cb06ca8e3a0a25
[2017/06/10 13:19:31] [message] Memory: current=245M, max=910M
[2017/06/10 13:19:32] [message] start startup getLicenseKey on 10-六月-2017
[2017/06/10 13:19:32] [message] getLicenseKey in local …
[2017/06/10 13:19:32] [message] getLicenseKey from server …
[2017/06/10 13:19:32] [message] finish startup getLicenseKey
[2017/06/10 13:19:32] [message] getVerifiedLicenseKey: null; state=Evaluating
[2017/06/10 13:19:32] [warning] Installation properties not found
[2017/06/10 13:19:32] [warning] Suite dir not found
[2017/06/10 13:19:32] [message] Workspace: /Users/cool/Library/Application Support/VisualParadigm/ws
[2017/06/10 13:19:32] [warning] java.sql.SQLException: [SQLITE_ERROR] SQL error or missing database (no such table: PROJECT_INFO)
at org.sqlite.core.DB.newSQLException(DB.java:890)
at org.sqlite.core.DB.newSQLException(DB.java:901)
at org.sqlite.core.DB.throwex(DB.java:868)
at org.sqlite.core.NativeDB.prepare(Native Method)
at org.sqlite.core.DB.prepare(DB.java:211)
at org.sqlite.jdbc3.JDBC3Statement.executeQuery(JDBC3Statement.java:81)
at v.cdp.w.y(:121)
at v.cdp.aa.b(:586)
at v.cdp.a.a(:281)
at v.cdp.a.a(:208)
at v.cdp.w.a(:80)
at v.clb.q.(:44)
at v.clb.q.(:29)
at v.cdl.az.a(:132)
at v.cdl.az.b(:104)
at v.cdl.az.(:63)
at v.cdl.dl.a(:6315)
at v.cdl.dl.a(:6254)
at v.cdl.dl.a(:6245)
at v.cdl.dl.a(:4129)
at v.cdl.dl.a(:4121)
at v.cez.bra.a(:58)
at v.aud.aq.a(:665)
at v.atq.adk.a(:15)
at v.aud.dc.a(:349)
at v.aud.dc.a(:54)
at v.aud.dd.run(:159)
at java.lang.Thread.run(Thread.java:745)

[2017/06/10 13:19:33] [warning] java.sql.SQLException: [SQLITE_ERROR] SQL error or missing database (no such table: PROJECT_INFO)
at org.sqlite.core.DB.newSQLException(DB.java:890)
at org.sqlite.core.DB.newSQLException(DB.java:901)
at org.sqlite.core.DB.throwex(DB.java:868)
at org.sqlite.core.NativeDB.prepare(Native Method)
at org.sqlite.core.DB.prepare(DB.java:211)
at org.sqlite.jdbc3.JDBC3Statement.executeQuery(JDBC3Statement.java:81)
at v.cdp.w.y(:121)
at v.cdp.aa.b(:586)
at v.cdp.a.a(:281)
at v.cdp.a.a(:208)
at v.cdp.w.a(:80)
at v.clb.q.(:49)
at v.clb.q.(:29)
at v.cdl.az.a(:132)
at v.cdl.az.b(:104)
at v.cdl.az.(:63)
at v.cdl.dl.a(:6315)
at v.cdl.dl.a(:6254)
at v.cdl.dl.a(:6245)
at v.cdl.dl.a(:4129)
at v.cdl.dl.a(:4121)
at v.cez.bra.a(:58)
at v.aud.aq.a(:665)
at v.atq.adk.a(:15)
at v.aud.dc.a(:349)
at v.aud.dc.a(:54)
at v.aud.dd.run(:159)
at java.lang.Thread.run(Thread.java:745)

[2017/06/10 13:19:33] [error] java.lang.NullPointerException
at v.cdp.aa.b(:586)
at v.cdp.a.a(:281)
at v.cdp.a.a(:208)
at v.cdp.w.a(:80)
at v.clb.q.(:49)
at v.clb.q.(:29)
at v.cdl.az.a(:132)
at v.cdl.az.b(:104)
at v.cdl.az.(:63)
at v.cdl.dl.a(:6315)
at v.cdl.dl.a(:6254)
at v.cdl.dl.a(:6245)
at v.cdl.dl.a(:4129)
at v.cdl.dl.a(:4121)
at v.cez.bra.a(:58)
at v.aud.aq.a(:665)
at v.atq.adk.a(:15)
at v.aud.dc.a(:349)
at v.aud.dc.a(:54)
at v.aud.dd.run(:159)
at java.lang.Thread.run(Thread.java:745)

[2017/06/10 13:19:33] [error] java.lang.NullPointerException
at v.cdl.dl.eA(:6527)
at v.cez.brp.a(:329)
at v.cdl.dl.b(:4656)
at v.cdl.dl.a(:4489)
at v.cdl.dl.a(:4471)
at v.cdl.dl.a(:4454)
at v.cdl.dl.(:3878)
at v.cdl.dl.(:3830)
at v.cdl.dl.(:3823)
at v.aud.aq.b(:1512)
at v.atq.wp.(:4958)
at v.aud.dc.a(:354)
at v.aud.dc.a(:54)
at v.aud.dd.run(:159)
at java.lang.Thread.run(Thread.java:745)

[2017/06/10 13:19:33] [message] Exception in thread “Thread-3”
[2017/06/10 13:19:33] [message] java.lang.NullPointerException
[2017/06/10 13:19:33] [message] at v.aud.dc.a(:364)
[2017/06/10 13:19:33] [message] at v.aud.dc.a(:54)
[2017/06/10 13:19:33] [message] at v.aud.dd.run(:159)
[2017/06/10 13:19:33] [message] at java.lang.Thread.run(Thread.java:745)


#2

This is just a guess on my part, but it looks to me as if you (accidentally?) removed specific directories which were needed by VP. I conclude as much based on the errors and warnings about VP being unable to find certain directories.