Document generator leaves out images and tables


Hi, I have created a business process doc and would like to export it. The document contains both diagrams and tables (in the element notes). I encounter the following problems when generating:

  • The pdf export doesn’t include any (diagram) images. I tried both the svg and png options
  • The word export does include the images but leaves out most tables. Only the last table is generated properly.

The html export does do the trick, but being able to generate physical documents is essential for our project.


Hi, Karin Severein
I tested on a simple business process diagram + doc composer. Cannot repeat those problems.

Can you send me the log file, or problematic word/pdf report to us for checking?

You can send it to
Please make sure you have included the URL of this forum post in your email. Thanks!


Hi Peter, I just sent you the requested examples. Hopefully this will help you in addressing the issue.



PDF missing Image

This problem should be fixed in yesterday. You can update to latest patch to try it.
It is a problem on failed to load any image file (no matter it is diagram image, or model icon, etc…).
I said should be fixed, it is because your vp.log did not show the exception. So, I can not make sure did you meet the same problem.

FYI, How to update to patch.

Word Table

Sorry, we cannot find out the solution now.

We found that the 15th element’s Table Width has no such problem.
But the 19th element’s table has the problem.

We don’t know why their 5th column width are different between them. (15th is 3.42inch, 19th is 3.8inch)
It seems, a long word will make the table width bigger.
But both table’s Table Width are 100%. :thinking:

Would you mind sending us the project file to
For checking from the source code, what is difference between those 2 tables?
You may anonymize your project file by project anonymous tool:


I have installed the latest hotfix build (20180231) but unfortunately that didn’t solve the pdf issue. I have sent the anonimized project file to the support team. Hopefully that will help you.

Regards, Karin


Hi, please try the latest patch.

We check the Word Table problem now. Please wait. :wink:


Indeed the pdf issue is fixed, thanks!


Word Table issue is fixed.

The problem is cells’ width (in inches) overwrite the table’s width (100%); Finally, the table width becomes bigger than page width.

Please update to latest patch. Thanks.


Hi Peter, unfortunately it still doesn’t seem to work. I updated to Build 20180238di and refreshed the content of the document. Should I do anything else?


Sorry, finally we found the problem,
we should not make the tables to: auto resize to fit the contents

Please update to latest patch (Build 20180315am). Thanks.


Sorry but it still doesn’t work. I installed Build 20180315ap


Sorry, please send us ( your .docx
For checking those Table Properties.


I just sent the docx to the support team


Sorry, you are talking about UI of DocComposer, and seems we have no solution to solve it.
But it is lucky that, no problem after generating to Word .docx.

– more details —
DocComposer UI is showing the Table in HTML.

There is a Long Word showing in the table cell.
Since it is ‘one word’, so, no line-wrap applied on it.

Seems we can apply CSS style into the table:
display:inline-block; word-break: break-all;
to make line-wrap apply on each characters. But it will split a normal word into 2 lines too

Finally, sorry, we have no solution to break a long-word, but keep short-word.


I checked the doc composer UI and made sure the words are not too long. Now all tables fit on the page in the doc composer UI but still they are missing from the docx export. Do you need a new log file or new version of the anonymized project?


Sorry. seems I really got wrong on the problem.
I think the problem is Table Width is bigger than Paper Width.
but your problem is Table appear in Preview (DocComposer’s UI), but lost in .docx

Sorry, I try to find out which table is missing first. Please wait…


Sorry, I cannot find out which table is missing. Can you tell me which are missing??

In Preview, I found 6 elements have Table: 9th, 15th, 19th, 23th, 27th, 28th
Compare to .docx, these 6 elements have those tables.




I think I finally understand … I use LibreOffice and it seems that program doesn’t render the tables. I have opened the same document on another computer using MS Office and then I do see the tables. So I guess the issue is that there is a problem in the docx / odt conversion? Looks a lot like this issue I have tried opening the document in Google docs but this causes an error as well. So it seems the problem is in non MS products?

Do you have experience with Libre / Open Office users? Are there any settings in the document generator that could help with this issue? Otherwise I guess this issue can be closed.


Or do you have plans for adding .odt generation options?


Which version do you use? Because this seems a bit odd to me, especially if you keep in mind that the generated Word documents can even be used with Office 2010 (which is what I’m using). I did a few tests myself (using the latest patch) and I have no issues with *.docx documents within Word 2010 as well as LibreOffice Writer 6.0. ( to be precise).

However, I think I did come across another small bug: I also tried to add a picture in my doc composer and the picture did show up within the Word document but was left out of the PDF document. So I wonder if that’s also a bug of some sort…

But yeah, my suggestion would be to try with LibreOffice 6.